Some students saw slower page loads for about 25 minutes while a database node was rebalancing. No data was affected and all services stayed available.
We're investigating reports of slower page loads across the student portal.
Identified
Identified a database index rebuild overlapping peak traffic as the cause. Pausing it now.
Monitoring
The rebuild is paused and latency has returned to normal. Monitoring to confirm.
Resolved
Fully resolved. No data was affected and all services stayed available throughout.
Postmortem Published
Postmortem published — see root cause and preventive actions below.
Postmortem
Root Cause
A routine index rebuild on the primary database ran hotter than expected during peak evening study hours, adding latency to read queries across the portal.
Resolution
The rebuild was paused and rescheduled to an off-peak window; query latency returned to normal within minutes.
Lessons Learned
Index maintenance wasn't gated to off-peak hours, so a routine operation overlapped with peak student traffic.
Preventive Actions
Index and vacuum operations are now restricted to a nightly off-peak window and gated behind a live-load check before they run.